Register                
Results 1 to 6 of 6

Thread: Hunter 44860 RH%

  1. #1
    Junior Member

    User Info Menu

    Hunter 44860 RH%

    Hello! I just recently moved into a repo home that has the Hunter 44860 thermostat. The air has been working fine. Now it is time to use the heat. The heat will only kick on if you have the thermostat set to the Auto (heat and cool) mode and if the RH% is 75%. Why does it only work on this setting? And what is RH%?

    Thanks!

  2. #2
    HVAC Thermostat Specialist

    User Info Menu

    RH = Relative humidity... I'm unsure why it would only work the way you describe... Here is the manual: http://www.hunterfan.com/uploadedFil...002%282%29.pdf

    75% RH is way too high

  3. #3
    HVAC Thermostat Specialist

    User Info Menu

    Does the word HOLD appear on the screen?

  4. #4
    Junior Member

    User Info Menu

    If I do not use the high RH% it doesn't seem to work. I will try to lower it and see what happens. It also doesn't kick on when the house temperature falls below the set temp. I have it set on 74 and it just kicked on with the house temp at 71. The air coming out feels cold. What should the RH% be on?

  5. #5
    HVAC Thermostat Specialist

    User Info Menu

    Sounds liek the previous owner miswired the thermostat.

  6. #6
    Junior Member

    User Info Menu

    Thank you everyone for your quick response. I actually reset the thermostat to factory settings when we moved in in September. The unit was working perfect with the air conditioning. I checked the settings for the heat and they were all wrong! It reset to a conventional system and I have a heat pump. It also reset to Gas/Oil Furnace and I have electric. When I changed those settings and set the RH% on 45% and changed the temperature variance to be within 2 degrees, the unit is working perfectly!!!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •