Page 2 of 2 FirstFirst 12
Results 7 to 8 of 8

Thread: RTH9580 Wi-Fi Time incorrect

  1. #7
    Junior Member

    User Info Menu

    I had the same issue. The only way to get the Honeywell Thermostat to show the correct time was to change the Time Zone from Abu-Dhabi (+4hrs) to Kuwait (+3hrs). Can't see to configure Thermostat summer time change.

    Update amazon now offers a free smart home consultation

  2. #8
    Junior Member

    User Info Menu

    Cool almost worked

    Quote Originally Posted by charbs1979 View Post
    This works on the Honeywell thermostat but with a couple more steps. The following worked for me:
    1) Disable the Wi-Fi as described above
    2) Once back to the main display, touch "Clock"
    3) "Internet Time" is no longer displayed and you're now able to manually set the clock
    4) Using the above steps, re-enable Wi-Fi.

    Hope it works for you all too.
    This looked to be a great idea .. and I was excited when I disabled the WIFI and was able to change the clock .. and reenable the autoDST function. Unfortunately, when I reenabled the WIFI .. the clock went back to the original time .. aarrgghh!!! .. any other ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts