Page 1 of 2 12 LastLast
Results 1 to 6 of 12

Thread: Honeywell RTH8580WF Wifi Setup Issue

  1. #1
    Junior Member

    User Info Menu

    Honeywell RTH8580WF Wifi Setup Issue

    I have obtained a used Honeywell RTH8580WF Thermostat. I have successfully installed and setup everything on the thermostat except for the Wifi Network. It never states it is in Wifi Setup as it should. I have reset the thermostat to no avail. I have also checked Setup Option 900 to verify it is on "0". I have also turned the Wifi Setting 890 to off by selecting "0" on the setup screen. Once that has been entered and setup completed, I then go back to change Setting 890 to "1" to turn on Wifi. Once the setup menu is completed from here, it never comes up stating it is in Wifi Setup mode. I have searched low and high for an answer. Someone please help. Also, I have tried contacting Honeywell Support but I tend to have suicidal thoughts if forced to stay on hold for 30+ minutes with terrible hold music.

    Update amazon now offers a free smart home consultation

  2. #2

    User Info Menu

    Have you setup a account on the Honeywell Total Connect Comfort site?
    Have you registered the thermostat on the Total Connect Comfort site using the thermostat MAC ID and MAC CRC?

  3. #3
    Junior Member

    User Info Menu

    That's part of the issue. The RTH8580WF never asks to connect to my router in order to become available to register on the Total Connect Comfort site. It says to verify the internet connection on the device which I know it isn't connected. I also just called the Honeywell Support center and went through the usual: reset the thermostat, check the settings, and was it installed correctly. After all of these were debunked, the representative then asked what system I had. I told him it is a Heat Pump with backup Gas Furnace. He then tried to tell me that it wasn't compatible with this system when I know good and well that it is compatible. I think he was just looking for a way to end the call with another issue to be resolved. I could have gotten more help from the wall I'm standing in front of.

  4. #4

    User Info Menu

    I am not sure what the issues is or how to resolve it. I was thinking that you could try to remove the battery and then reinstall it to see if that does some type of additional reset.

  5. #5
    Junior Member

    User Info Menu

    I tried that. So I'm thinking my next option is to try and return this defective thermostat and get another.

  6. #6
    Junior Member

    User Info Menu

    Ok. So after I've come to the realization that this unit is possibly deffective, I decided to take it apart and verify everything was present and in place.

    I took the face plate off and then removed the touch screen/main module to reveal the Wifi Module behind it. Once I verified it was there, I put the touch screen/main module back in place. After pushing it into the frame it clicks into place but I notice there is still a little wiggle room between it and the Wifi Module.

    Wi-Fi 7 Day Smart Programmable Touchscreen Thermostat, Works with Amazon Alexa, SmartThings, Google Home, IFTTT

    So I replace the face plate and turn the thermostat over to access the Wifi Module cover. I take it off and give it a gentle push. I then notice it snaps into place to come in full contact with the main module. I put it back together and install the thermostat to the base plate on the wall.

    After going through the main setup of the date and time, the information bar up top read "Wifi Setup". It's the coveted readout I've been looking for this whole time!

    So in the end, the thermostat was under the assumption it wasn't a Wifi capable unit due to the Wifi module not being aligned properly. I am happy that it was something so simple and I hope that anyone else who has this issue is able to find my simple solution.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts